Calulcations YTD in the cube

View previous topic View next topic Go down

Calulcations YTD in the cube

Post  sssqllearner on Tue Oct 14, 2014 9:05 am

Hi,

Our YTD calculation in cube is not working for some reason for half of the year i.e. our year is divided into 2 cycles. cycle 1 is from January until June and cycle 2 is from July to December. For some reason YTD is working correctly for 1st cycle but when we are doing calculation for cycle 2 the sales are not adding correctly in the cube. This is very tricky situation because this is the same issue for last year where cycle 1 sales are matching but cycle 2 figures are incorrect.

Our YTD calcuations is something like below:
SCOPE([Date Utility].[Date Accumulations].[YTD]);  
   -- Date
   SCOPE([Date].[Date].[Date].Members);
       this = Aggregate(
               Exists(
   [Date].[Date].[Date].Members, -- get siblings within ...
Exists(
[Date].[Year].[Year].Members,
[Date].[Date].CurrentMember -- ... corresponding year
)    
               ).Item(0).Item(0) : [Date].[Date].CurrentMember,
               ([Measures].CurrentMember, [Date Utility].[Date Accumulations].DefaultMember)
              );
   END SCOPE;

do you know what can be the reason behind this? for your reference the above script is used in various other cubes and those cubes are fine. It is just one cube which is causing these issues.


thanks,
regards.

sssqllearner

Posts : 8
Join date : 2014-09-16

View user profile

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum